0
velocity-96

neptune's indicated speeds

Recommended Posts

im curious about other neptune owners opinion about the speeds indicated. mine worn on my wrist, is rarley correct. im not just talking a few mph different from my protrack. sometimes it will tell me im going 0mph in the middle of the jump. other times its just way off. im a freeflyer and theres no way im averaging 99mph headown. shit i wish i had that much range! id say it seems correct less than 1/2 the time. after having mine for over a year now i must say im not at all impressed. i find the buttons very hard to press and it takes too long to access info. its also crapped out on the ride up twice leaving me without a visual altimeter. im anxious for larsen and b's new alti's coming out soon. im going to sell my neptune as soon as they're released and give them a try. ive always been happy with my protrack and pro dyter. never faiied me once.

Share this post


Link to post
Share on other sites
Hmmmm, i haven't had mine long and have only jumped it a few times but i'm very pleased with it and have no problems with the indicated speeds. (Then again i jump a dytter not a protrack so i can't compare it to anything).

I still wear an Alti III Galaxy on my wrist though and have my neptune on a strap round my left thigh to aid me while swooping.

Advertisio Rodriguez / Sky

Share this post


Link to post
Share on other sites
Sorry you're having problems...

Me?
No speed-indication problems at all.
Buttons hard to push? I like it because they don't get pushed accidently.
Too long to access info? Do you mean too many menus or slow response time after pressing the button? I don't have a problem with either.

The only thing I have an issue with is Battery Low indication but a regular battery replacement schedule will fix that.

Let us all know how the new L&B works out for you, though.
My reality and yours are quite different.
I think we're all Bozos on this bus.
Falcon5232, SCS8170, SCSA353, POPS9398, DS239

Share this post


Link to post
Share on other sites
I have only 3 jumps on mine, so I really can't comment on the longevity - but so far it has been balls on. I need to replace the batteries (I bought it about 4 months ago and played with it untl I knew it blindfolded), but it has been quite the gadget for me. Several jumpers at the DZ use the Alti Neptune as well. Everyone I have talked to about it has nothing but good things to say about it.

I say, if you are spending money on it, get something you are hapy with. If the Alti Neptune is not working well for you, get something that will.
_________________________________________
Twin Otter N203-Echo,29 July 2006
Cessna P206 N2537X, 19 April 2008
Blue Skies Forever

Share this post


Link to post
Share on other sites
Sounds like you are running a pretty old firmware version. I know this because you say that your buttons are hard to press and that the response time to the buttons is slow. This problem was fixed long ago with one of the firmware updates. The buttons are now more sensitive and the load and access times are 100x faster than before. My Neptune has never caused me any problems in the year that i've had it and over 100 jumps i've put on it. Its also always bang on when compared to my protrack. I have worn it on my hand, in my helmet and on my mudflap.

Get an update and replace your battery....it should help alot!
Flying Hellfish #470

Share this post


Link to post
Share on other sites
Quote

Quote

Get an update and replace your battery....it should help alot!



How/Where can you do that? ...The software part, I know how to change a batt.:P



Here we are, the great AFS guys. We update Neptunes, change diapers, open beer bottles, drink them, notify next of kin, what have you... Our famous last words are: "This new beta software functionality is fantastic!" Your Neptune has come to its flawless working state through a field of experience littered with AFS guys corpses... Cherish us already! I need a backrub.

Edit: Failing that (if you are reluctant to give backrubs that is), you can send the unit to Lara at Alti-2; read the site to find out the address.

Share this post


Link to post
Share on other sites
Before V2.6.0 my average speed indication on the Neptune at 3,6,9,12k and overall seemed accurate and matched the data that I'd see in Paralog. Now since in V2.6.0 "Jump log speed calculations have been improved to prevent turbulent airflow result in wild velocity readings." these calcluations seem way off. I'm waiting for the next version to actually fix what they broke, similar to the battery indication changes they made recently. I've seen similar results on two other Neptunes. I don't have mine in front of me, but occasionaly I'll see stuff like 250+ mph when I know I haven't gone that fast, or stuff like you said 99mph in a head down. Besides that I love the Neptune.
BASE 1224, Senior Parachute Rigger, CPL ASEL IA, AGI, IGI
USPA Coach & UPT Tandem Instructor, PRO, Altimaster Field Support Representative

Share this post


Link to post
Share on other sites
Quote

... is rarley correct ... its also crapped out on the ride up twice leaving me without a visual altimeter ... im going to sell my neptune as soon as they're released



hmm...
you don't like your equipment, according to you it's not working properly and you seem to believe it's too dangerous to keep on using it, so what will you do to correct the problem?
oh, yeah ... sell it to someone else so it's no longer your problem. good thinking!
Padalcek - CCO, HF-17
http://www.theflyinghellfish.com
I'm not a real skydiver - but I do play one on dz.com.

Share this post


Link to post
Share on other sites
Version 2.6.0 is very bugged. I have never had so many problems with any other previous versions in including Betas. I am also a FR for Alti-2 and expressed my concerns about the latest version quite few times.

I know they are working on it but please if you have problems with the 2.6.0 e-mail Alti-2 being very specific what the problems are.
Memento Audere Semper

903

Share this post


Link to post
Share on other sites
V-9. Call Alti-2 and tell them about your problem. I had some similar issues after that shitty firmware patch as well. I sent it back and they "fixed" it. I got it back and while playing with it, it decided to do a jump all on its own. And even log it. It went nuts. It proceeded to freak out for whatever reason every couple hours making noises from the Ms.Pacman era. I called them again and they sent me a new one before I sent the old one back. They are a very good Co. with awesome customer service.

And if anyone needs some older firmware versions, I have a couple that work.

Later

------------------------------

Controlled and Deliberate.....

Share this post


Link to post
Share on other sites
yeah thats the reason. so you interested in buying it?

where the hell did i state its too dangerous to jump?
i love when people add shit to peoples posts so they can appear so sharp! do you feel better about yourself now.
implying im trying to pawn some crap off on someone and put their fuckin life in danger is rediculous!!!
so i guess everyone selling a canopy that they've had a mal on is fucked up too. ooooo wait thats different and im sure you'll tell me why. its because it contradicts your thoughts.

you know i dont know why i bother replying to this kind of bullshit,
im done
have a nice fuckin day

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account. It's free!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0