Forums: Dropzone.com: Error and Bug Reports:
Something weird is happening with new unread posts lately

 

First page Previous page 1 2 Next page Last page  View All

unkulunkulu  (C License)

Feb 12, 2013, 4:10 AM
Post #1 of 27 (1776 views)
Shortcut
Something weird is happening with new unread posts lately Quote | Reply

The thread icon is partly amber as if there are new messages in the thread. When clicked, it shows the first post in the thread and the new messages are not marked with a red "NEW" text even if the thread consists of a single page. However there are actually new messages (one can tell by the date/time of the post).

It started recently (less than a week probably, although can't tell for sure). It is reproduced somewhat randomly, around 50/50 chance of correct/incorrect work.

Browser is FF 18.0.1 (oh god), TZ is GMT+4 should it matter :)

Anyone can confirm this?


Premier Meso
Administrator
Feb 12, 2013, 4:14 AM
Post #2 of 27 (1736 views)
Shortcut
Re: [unkulunkulu] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

I'll keep an eye on this and see if I can work out what the issue is if it presents itself.


The111  (D 29246)

Feb 21, 2013, 2:31 AM
Post #3 of 27 (1681 views)
Shortcut
Re: [unkulunkulu] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

I'm seeing it too. Usually it scrolls to the first unread post, and that post has a "new" marking next to it. Now it just opens at the beginning of the thread, and if I scroll to the end, the new posts do not have the marking.


Premier Meso
Administrator
Feb 21, 2013, 3:16 AM
Post #4 of 27 (1673 views)
Shortcut
Re: [The111] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Is it happening on all sections of the forums or particular ones? When you view this post, is there a 'NEW' above this post? I see the 'new' alert on your post. Just trying to establish where the issue lies.


The111  (D 29246)

Feb 21, 2013, 5:22 AM
Post #5 of 27 (1652 views)
Shortcut
Re: [Meso] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

In reply to:
Is it happening on all sections of the forums or particular ones? When you view this post, is there a 'NEW' above this post? I see the 'new' alert on your post. Just trying to establish where the issue lies.

No, I did not see the 'NEW' on this post. I've seen the issue happen in multiple forums, though I just did a quick experiment and clicked on many unread threads in the bonfire, and for every one I got the 'NEW' indicator. Then I went to general skydiving and clicked on several unread threads, and did not get the indicator for any of them. Same for this forum here, which would explain my first sentence in this post.


Premier skymama  (D 26699)
Moderator
Feb 22, 2013, 6:35 PM
Post #6 of 27 (1624 views)
Shortcut
Re: [Meso] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

I just came into this forum to alert you; glad I'm not the only one.

So far tonight, I've noticed it in Women's, Events and General. It does seem to be working in Bonfire.


The111  (D 29246)

Feb 22, 2013, 8:30 PM
Post #7 of 27 (1615 views)
Shortcut
Re: [skymama] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Also, the day after I made my last post, I tried all the same stuff again and there were no problems. I wasn't sure if the bug had been fixed already, or if this was just another fluke which will make it harder to identify. Sounds like the latter. Unsure


unkulunkulu  (C License)

Feb 25, 2013, 8:04 AM
Post #8 of 27 (1568 views)
Shortcut
Re: [Meso] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

So from your account this is not reproduced? Maybe you should try from a test account? Because it happens quite regularly, for example, when I tried to read the new messages in this thread Blush Angelic


christelsabine  (D 10828)

Feb 25, 2013, 8:12 AM
Post #9 of 27 (1561 views)
Shortcut
Re: [Meso] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Same here in different forums.


theonlyski  (D License)

Feb 25, 2013, 8:52 AM
Post #10 of 27 (1555 views)
Shortcut
Re: [Meso] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Just experienced it on this thread: http://www.dropzone.com/...;;page=unread#unread

I never viewed it before now, and it's not saying NEW on any of the posts.

Same here: http://www.dropzone.com/...;;page=unread#unread


(This post was edited by theonlyski on Feb 25, 2013, 8:58 AM)


Premier skymama  (D 26699)
Moderator
Feb 27, 2013, 4:41 AM
Post #11 of 27 (1513 views)
Shortcut
Re: [theonlyski] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Also, when you open a thread in the forums where this is happening, it doesn't bring you to the bottom where the new posts are, it just stays at the top. It happened when I opened this thread.


Premier skydiverek  (C 41769)

Feb 27, 2013, 12:32 PM
Post #12 of 27 (1490 views)
Shortcut
Re: [skymama] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Same here, in this thread.


Premier Meso
Administrator
Feb 27, 2013, 11:46 PM
Post #13 of 27 (1457 views)
Shortcut
Re: Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Thanks for everyone's input. I understand the issue at hand, now just to find out what could be causing it and to fix it.


Andy9o8  (D License)

Mar 3, 2013, 6:33 AM
Post #14 of 27 (1402 views)
Shortcut
Re: [Meso] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Hello, Sir.

2 things I noticed today:

1. Threads that I've already read-thru still have the shaded icon (when viewing the thread list) indicating I hadn't read them yet.

2. I just replied to Person X's post. Then I got an e-mail notification saying that Person X had just replied to one of my posts. When I clicked on the link in the e-mail, it took me to the post of Person X that I'd just replied to - but Person X had not replied to any post of mine in that thread.


BillyVance  (D 18895)

Mar 3, 2013, 9:24 AM
Post #15 of 27 (1380 views)
Shortcut
Re: [unkulunkulu] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Good to see others have had the same problem and it's not just me. Laugh


BillyVance  (D 18895)

Mar 3, 2013, 9:26 AM
Post #16 of 27 (1378 views)
Shortcut
Re: [skymama] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

In reply to:
I just came into this forum to alert you; glad I'm not the only one.

So far tonight, I've noticed it in Women's, Events and General.

Safety and Training too.


Premier Meso
Administrator
Mar 3, 2013, 10:48 PM
Post #17 of 27 (1348 views)
Shortcut
Re: [BillyVance] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Just an update with this, we have forwarded the problem to our host provider who is looking into the issue.


unkulunkulu  (C License)

Mar 27, 2013, 4:19 AM
Post #18 of 27 (1216 views)
Shortcut
Re: [unkulunkulu] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

While the issue is still there somehow, I've just run into its evil twin:
In General Discussions I came upon a thread I had never seen before: "Turbulence question", the icon to the left confirmed it: two sheets of amber color, so all the messages should've been unread, but when I pressed the link it led to
http://www.dropzone.com/cgi-bin/forum/gforum.cgi?post=4461911;sb=post_latest_reply;so=ASC;forum_view=forum_view_collapsed;;page=unread#unread

and it showed page 2, full of unread messages, but still, it had to be page 1.


(This post was edited by unkulunkulu on Mar 27, 2013, 4:20 AM)


christelsabine  (D 10828)

Mar 27, 2013, 9:56 AM
Post #19 of 27 (1193 views)
Shortcut
Re: [unkulunkulu] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Entering this site is hard work, actually - at first it takes centuries until all ads are established, and after clicking on "NEW", I end up on first page and have to scroll down to the new post. Trying to enter "Stammtisch" is killing me Mad - it takes the longest time.

French ads, German ads - how many does it need? Crazy


Premier Meso
Administrator
Mar 27, 2013, 10:04 AM
Post #20 of 27 (1191 views)
Shortcut
Re: [christelsabine] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

While we had someone take a look at the new post problem, they weren't able to replicate it to solve it, I will get back in touch with them to get it sorted.

With regards to the ads, unfortunately that sounds like those ads are not something we serve, but rather google ads. If you can give me screenshots of the ads that take extended time to load we can look into it, but I suspect it may be a google ad.


BillyVance  (D 18895)

Mar 27, 2013, 11:01 AM
Post #21 of 27 (1178 views)
Shortcut
Re: [Meso] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Just an FYI, the problem with opening a thread with unread posts and being kicked to the beginning of it is still occurring.


theonlyski  (D License)

Mar 27, 2013, 7:49 PM
Post #22 of 27 (1153 views)
Shortcut
Re: [Meso] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

I'll give you a hint:

Quote:
[22:41:01.373] The page was reloaded, because the character encoding declaration of the HTML document was not found when prescanning the first 1024 bytes of the file. The encoding declaration needs to be moved to be within the first 1024 bytes of the file. @ http://www.dropzone.com/cgi-bin/forum/gforum.cgi?post=4452905;sb=post_latest_reply;so=ASC;forum_view=forum_view_collapsed;;page=unread#unread:50

That explains why the page is showing no posts with the NEW indicator, because it's been reloaded.

Wink

ETA:
Ahh what the hell, I'm in a giving mood:

In your gforum.cgi file, you'll probably see this line inside the <head> tags:

<meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />

Immediately above it is probably some javascript crap.

I would move that meta tag line to just under the <title> line.

EETA: This probably has something to do with the embedded images function, but I think moving the meta line up to just under the title (or even above it) would alleviate this situation.


(This post was edited by theonlyski on Mar 27, 2013, 8:07 PM)


unkulunkulu  (C License)

Mar 28, 2013, 4:22 AM
Post #23 of 27 (1119 views)
Shortcut
Re: [theonlyski] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Nice catch! Where is that log coming from?
It also explains the recent issue showing the second page of completely new thread: it reloads and goes for the next unread message (i.e. page 2)


theonlyski  (D License)

Mar 28, 2013, 5:22 AM
Post #24 of 27 (1085 views)
Shortcut
Re: [unkulunkulu] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

Firefox web debug tool. Wink

Looks like Meso got it fixed, anyone else still having this issue?


theonlyski  (D License)

Mar 28, 2013, 6:35 AM
Post #25 of 27 (1065 views)
Shortcut
Re: [skymama] Something weird is happening with new unread posts lately [In reply to] Quote | Reply

In reply to:
So far tonight, I've noticed it in Women's, Events and General. It does seem to be working in Bonfire.

Oddly enough, that makes plenty of sense. Smile


First page Previous page 1 2 Next page Last page  View All

Forums : Dropzone.com : Error and Bug Reports

 


Search for (options)