Forums: Dropzone.com: Error and Bug Reports:
Bug in classified

 

First page Previous page 1 2 Next page Last page  View All

DiverMike  (C 40024)

Nov 27, 2012, 5:30 AM
Post #1 of 50 (6222 views)
Shortcut
Bug in classified Quote | Reply

 fatal error has occured:

GT::SQL (16658): Unable to load subclass: 'Links::Table::ClickTrack': "%STASH" is not exported by the Links module
Can't continue after import errors at /home/dropzone/dropzone.com/cgi-bin/classifieds/admin/Links/Table/ClickTrack.pm line 21
BEGIN failed--compilation aborted at /home/dropzone/dropzone.com/cgi-bin/classifieds/admin/Links/Table/ClickTrack.pm line 21.
Compilation failed in require at /var/home/dropzone/lib/GT/SQL/Base.pm line 587.
, Can't locate Links/Table.pm in @INC (@INC contains: /home/dropzone/dropzone.com/cgi-bin/classifieds/admin /var/home/dropzone/dropzone.com/cgi-bin/photos/admin /lib /home/dropzone/dropzone.com/cgi-bin/forum/admin /home/dropzone/dropzone.com/cgi-bin/photos/admin /var/home/dropzone/lib /var/home/dropzone/lucene/lib /var/home/dropzone/dropzone.com/cgi-bin/community/private/lib /var/home/dropzone/dropzone.com/cgi-bin/gmail/admin /var/home/dropzone/dropzone.com/cgi-bin/adcycle /var/home/dropzone/dropzone.com/cgi-bin/gear/admin /var/home/dropzone/dropzone.com/cgi-bin/videos/admin /var/home/dropzone/dropzone.com/cgi-bin/remember/admin /var/home/dropzone/dropzone.com/cgi-bin/incidents/admin /var/home/dropzone/dropzone.com/cgi-bin/fatalities/admin /var/home/dropzone/dropzone.com/cgi-bin/dropzone/admin /var/home/dropzone/dropzone.com/cgi-bin/safety/admin /var/home/dropzone/dropzone.com/cgi-bin/stolen/admin /var/home/dropzone/dropzone.com/cgi-bin/classifieds/admin /var/home/dropzone/dropzone.com/cgi-bin/events/admin /var/home/dropzone/dropzone.com/cgi-bin/calendar/admin /var/home/dropzone/dropzone.com/cgi-bin/forum/admin /var/home/dropzone/dropzone.com/cgi-bin/weather/hamlib /var/home/dropzone/rt/lib /usr/lib/perl5/5.8.4/x86_64-linux /usr/lib/perl5/5.8.4 /usr/lib/perl5/site_perl/5.8.4/x86_64-linux /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.4/x86_64-linux /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl . /usr/ /usr/lib/perl /home/dropzone/dropzone.com/cgi-bin/community/private/lib) at /var/home/dropzone/lib/GT/SQL/Base.pm line 587.
at (eval 890) line 3.
Please enable debugging in setup for more details.

OK

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@dropzone.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Premier Meso
Administrator
Nov 27, 2012, 6:22 AM
Post #2 of 50 (6081 views)
Shortcut
Re: [DiverMike] Bug in classified [In reply to] Quote | Reply

Hi,

Thanks, we have just turned over to the new templates on the classifieds and will be spending the next couple of days ironing out the bugs... This being one of them.

If you guys come across any other bugs with the new template please post em here.


michael

Nov 27, 2012, 6:42 AM
Post #3 of 50 (6072 views)
Shortcut
Re: [Meso] Bug in classified [In reply to] Quote | Reply

Hi,

More funky results. On the 'Classifieds' page, Select 'Classifieds' from the Search drop down box. Enter a search term a click 'Go' :

Error! Must enter search engine

Same result in IE8 and Chrome 21.0.

Michael


DiverMike  (C 40024)

Nov 27, 2012, 9:02 AM
Post #4 of 50 (6043 views)
Shortcut
Re: [michael] Bug in classified [In reply to] Quote | Reply

Another Bug in the Gear section when navigating Aerodyne, Then Triathlon:
A fatal error has occured:

GT::SQL (3307): Unable to load subclass: 'Links::Table::ClickTrack': at (eval 2261) line 3.
Please enable debugging in setup for more details.

OK

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@dropzone.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


hottamaly  (D 15263)

Nov 27, 2012, 3:08 PM
Post #5 of 50 (6021 views)
Shortcut
Re: [Meso] Bug in classified [In reply to] Quote | Reply

I went to post an ad for "head gear" and it takes me to a drop down list for "AAD's".


Maksimsf  (B 37743)

Nov 27, 2012, 8:10 PM
Post #6 of 50 (6005 views)
Shortcut
Re: [hottamaly] Bug in classified [In reply to] Quote | Reply

In reply to:
I went to post an ad for "head gear" and it takes me to a drop down list for "AAD's".

Same thing, but was trying to post in "Reserve" section.

Also when I hit post an add - i get this:

OK
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@dropzone.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


(This post was edited by Maksimsf on Nov 27, 2012, 8:10 PM)


Premier Meso
Administrator
Nov 27, 2012, 11:21 PM
Post #7 of 50 (5986 views)
Shortcut
Re: Bug in classified [In reply to] Quote | Reply

We're working hard at getting all these bugs sorted out as soon as possible, I've managed to fix the search feature, so that should now work.


While we are working at fixing the main error when clicking on a link and getting an error... In the mean time, if you experience this problem, refreshing the page with the error should take you to the ad.


likestojump  (D License)

Nov 28, 2012, 7:23 AM
Post #8 of 50 (5968 views)
Shortcut
Re: [Meso] Bug in classified [In reply to] Quote | Reply

When editing an ad that's posted in the Containers section the listbox for Manufacturer is correct, but he listbox for the Type is populated by the items meant for the Reserve section.


likestojump  (D License)

Nov 28, 2012, 7:33 AM
Post #9 of 50 (5966 views)
Shortcut
Re: [Meso] Bug in classified [In reply to] Quote | Reply

#1
When posting an ad the Country listbox is mandatory, but the default state is blank. Seems like auto-populating is should be a no brainer, as the DB is queried on form load due to having the name and email being pre-populated. The dropdown is also unintuitively placed :(

leaving it blank results in the error that Maksimf showed. basejumper.com classifieds have an identical problem.

#2
The Premier Member Ads featured section is no longer updating with the new ads since the time of the template change.


likestojump  (D License)

Nov 28, 2012, 7:50 AM
Post #10 of 50 (5965 views)
Shortcut
Re: [Meso] Bug in classified [In reply to] Quote | Reply

When trying to Delete an ad (by going to Delete Ads link below the menu bar)

#1 - the title is "Delete Link" (should be Delete Ad)
#2 - not all ads are displayed. I had 44 ads running at the time of clicking, but only the first 14 were shown (sorted alphabetically), with no option to go to the next page.


sundevil777  (D License)

Nov 28, 2012, 12:23 PM
Post #11 of 50 (5953 views)
Shortcut
Re: [Meso] Bug in classified [In reply to] Quote | Reply

Many ads do not show the description of the item at all when you click on it - go to the "detail" of the ad.


likestojump  (D License)

Nov 28, 2012, 1:33 PM
Post #12 of 50 (5944 views)
Shortcut
Re: [sundevil777] Bug in classified [In reply to] Quote | Reply

In reply to:
Many ads do not show the description of the item at all when you click on it - go to the "detail" of the ad.

what he means is that there's a preview of the detailed description, but when you click on the actual ad, the contents of the description are blank.


sundevil777  (D License)

Nov 28, 2012, 7:11 PM
Post #13 of 50 (5918 views)
Shortcut
Re: [DiverMike] Bug in classified [In reply to] Quote | Reply

The denomination (dollars/pounds/whatever) of the price shows up, but not the actual price until you click on the actual ad.


Premier Meso
Administrator
Nov 28, 2012, 9:35 PM
Post #14 of 50 (5907 views)
Shortcut
Re: [sundevil777] Bug in classified [In reply to] Quote | Reply

Thanks for the input guys...

I will be tackling these issues and trying to get them as many as possible resolved today. Some are easy fixes, others will require a bit more work, but we will get the ads up to proper standards again soon.


Premier Meso
Administrator
Nov 29, 2012, 4:42 AM
Post #15 of 50 (5887 views)
Shortcut
Re: [likestojump] Bug in classified [In reply to] Quote | Reply

Quote:
#1 - the title is "Delete Link" (should be Delete Ad) - Fixed
#2 - not all ads are displayed. I had 44 ads running at the time of clicking, but only the first 14 were shown (sorted alphabetically), with no option to go to the next page.

With regards to the second one, I've tried changing the way it grabs the links, if you can see and let me know if you are still not seeing ads that should be shown, I can see if it's helped at all.


Premier Meso
Administrator
Nov 29, 2012, 4:44 AM
Post #16 of 50 (5886 views)
Shortcut
Re: [sundevil777] Bug in classified [In reply to] Quote | Reply

Quote:
The denomination (dollars/pounds/whatever) of the price shows up, but not the actual price until you click on the actual ad.

This problem as far as I know currently only exists on the 'featured links' listing on the main classifieds page, which is something we are busy working on.

But in the main category listings, items with prices should be shown, and appear to be.


Premier Meso
Administrator
Nov 29, 2012, 4:44 AM
Post #17 of 50 (5885 views)
Shortcut
Re: [likestojump] Bug in classified [In reply to] Quote | Reply

Quote:
Quote:
Many ads do not show the description of the item at all when you click on it - go to the "detail" of the ad.

what he means is that there's a preview of the detailed description, but when you click on the actual ad, the contents of the description are blank.

This was a problem where ads without images weren't displaying properly, this issue should now be fixed.


Premier Meso
Administrator
Nov 29, 2012, 6:01 AM
Post #18 of 50 (5882 views)
Shortcut
Re: [likestojump] Bug in classified [In reply to] Quote | Reply

Quote:
When editing an ad that's posted in the Containers section the listbox for Manufacturer is correct, but he listbox for the Type is populated by the items meant for the Reserve section.

This error should now be fixed.


Premier Meso
Administrator
Nov 29, 2012, 6:43 AM
Post #19 of 50 (5879 views)
Shortcut
Re: [likestojump] Bug in classified [In reply to] Quote | Reply

Quote:
#1
When posting an ad the Country listbox is mandatory, but the default state is blank. Seems like auto-populating is should be a no brainer, as the DB is queried on form load due to having the name and email being pre-populated. The dropdown is also unintuitively placed :(

leaving it blank results in the error that Maksimf showed. basejumper.com classifieds have an identical problem.

#2
The Premier Member Ads featured section is no longer updating with the new ads since the time of the template change.


Since #2 was the most important of the issue it took priority and should now be working. Ads that were submitted in the past 24 or so hours by premium members will not show up as such until I manually go through them and switch them to the correct link, if in 12 hours you still don't see any of your paid links displayed as they should... Send me a PM with the URL (anyone who is affected) and I'll switch them for you so long.


(This post was edited by Meso on Nov 29, 2012, 6:49 AM)


blueblur  (A 64923)

Nov 29, 2012, 9:04 AM
Post #20 of 50 (5861 views)
Shortcut
Re: [Meso] Bug in classified [In reply to] Quote | Reply

New Ads listings have gone from showing a preview and image thumbnail (cumbersome) to the title and date only, but all listing in a single paragraph with no break in between lines/items.


Premier Meso
Administrator
Nov 29, 2012, 10:33 AM
Post #21 of 50 (5854 views)
Shortcut
Re: [blueblur] Bug in classified [In reply to] Quote | Reply

That was just me trying to test some stuff... I will look into it a bit more when I'm back at the office tomorrow, for now I've just gone ahead and fixed the fact that the price was missing on the preview of the new ads listings.


monkycndo  (D License)

Nov 30, 2012, 4:44 AM
Post #22 of 50 (5823 views)
Shortcut
Bug in classified [In reply to] Quote | Reply

Tried to post an ad and got this error message.

OK
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@dropzone.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Premier Meso
Administrator
Nov 30, 2012, 5:05 AM
Post #23 of 50 (5822 views)
Shortcut
Re: [monkycndo] Bug in classified [In reply to] Quote | Reply

If you got that message the likelihood that you posted an ad without select a mandatory field is strong.

My assumption is that the country field was left without being changed, which would spit back that error. Going to work at getting it to just not be able to submit instead, which should prevent the sight of an error message when nothing is entered.


monkycndo  (D License)

Nov 30, 2012, 5:32 AM
Post #24 of 50 (5819 views)
Shortcut
Re: [Meso] Bug in classified [In reply to] Quote | Reply

Yep, missed country. Thanks.

Agreed, error message should be something to affect of check required fields versus what shows currently.

Also, the change back to the basic list of new ads is much easier to scan through.Smile


monkycndo  (D License)

Nov 30, 2012, 10:34 AM
Post #25 of 50 (5809 views)
Shortcut
Re: [Meso] Bug in classified [In reply to] Quote | Reply

When looking at the new ads section, the photo of the item does not pop up when you hover over the camera icon. They do appear when you go into the individual sections. Currently, you can see the attached photo in a small window when you hover over the camera icon. But if you click on the camera icon, it opens the item description instead of opening a larger window to view the photo.


First page Previous page 1 2 Next page Last page  View All

Forums : Dropzone.com : Error and Bug Reports

 


Search for (options)