Forums: Skydiving Disciplines: Photography and Video:
XTi firing when turned on - tongue switch

 


Psychonaut  (C License)

Jul 25, 2012, 8:26 AM
Post #1 of 9 (988 views)
Shortcut
XTi firing when turned on - tongue switch Can't Post

I know I've seen threads mentioning this before, but the search here sucks, I can't find it.

Sometimes as I flip my camera on, it starts shooting continuously. Sometimes 3 shots, sometimes it shoots as though it isn't going to stop. I've tried turning it on/off with the switched plugged/not plugged in, etc.

Any advice or links to the other threads, thanks


JSE  (D 28998)

Jul 25, 2012, 9:57 AM
Post #2 of 9 (952 views)
Shortcut
Re: [Psychonaut] XTi firing when turned on - tongue switch [In reply to] Can't Post

Check to make sure your switch is plugged in all the way. If thats not the problem then your switch is just wearing out. I used to go through at least two per season. That is the tell tale sign its time to replace the tongue switch.


theonlyski  (D License)

Jul 25, 2012, 10:36 AM
Post #3 of 9 (945 views)
Shortcut
Re: [JSE] XTi firing when turned on - tongue switch [In reply to] Can't Post

In reply to:
Check to make sure your switch is plugged in all the way. If thats not the problem then your switch is just wearing out. I used to go through at least two per season. That is the tell tale sign its time to replace the tongue switch.

He said he tried it with the switch not plugged in. Wink


Premier DSE  (D 29060)

Jul 25, 2012, 10:37 AM
Post #4 of 9 (943 views)
Shortcut
Re: [Psychonaut] XTi firing when turned on - tongue switch [In reply to] Can't Post

It could be possible the switch inside has worn out, and the contacts are touching each other?
Can you get a dummy 2.5mm plug from Radio Shack or similar and see if that stops the problem?


(This post was edited by DSE on Jul 25, 2012, 10:38 AM)


The111  (D 29246)

Jul 26, 2012, 1:54 PM
Post #5 of 9 (855 views)
Shortcut
Re: [Psychonaut] XTi firing when turned on - tongue switch [In reply to] Can't Post

Sounds like a short in the cable, connector molding, or switch. Easiest diagnostic with no science involved at all is to just get another tongue switch (or any sort of remote control, which you might find at Best Buy and could try out in the store for free) and see if it happens with that one too.

If it DOES happen with the 2nd switch... then you have probably serious problems. But I'll bet it doesn't.

Side note... trying to plug a switch in while the camera is on most likely will cause at least one shot to fire as the plug slides in and temporarily crosses contacts. Always plug and unplug while off, for the sake of convenience.


(This post was edited by The111 on Jul 26, 2012, 1:55 PM)


Skydivesg  (D 10938)

Jul 26, 2012, 10:18 PM
Post #6 of 9 (811 views)
Shortcut
Re: [The111] XTi firing when turned on - tongue switch [In reply to] Can't Post

I also find it useful to have a back up switch so I can just plug and go.

In fact I keep one rolled up inside the lining at the top of my helmet.

For some reason when one goes bad it's often while I'm in the plane.


Psychonaut  (C License)

Aug 10, 2012, 9:26 AM
Post #7 of 9 (650 views)
Shortcut
Re: [The111] XTi firing when turned on - tongue switch [In reply to] Can't Post

Sounds good guys. Got a new one to hook up this weekend, might as well keep the old in the helmet as a backup, a might-work-as-desired-might-not backup is better than no backup.


Premier DSE  (D 29060)

Aug 10, 2012, 9:35 AM
Post #8 of 9 (648 views)
Shortcut
Re: [Psychonaut] XTi firing when turned on - tongue switch [In reply to] Can't Post

if you send your old one to Conceptus, they've been pretty good about replacing them.


Psychonaut  (C License)

Aug 10, 2012, 1:49 PM
Post #9 of 9 (638 views)
Shortcut
Re: [DSE] XTi firing when turned on - tongue switch [In reply to] Can't Post

Put them on the list under L&B for service, thanks DSE.



Forums : Skydiving Disciplines : Photography and Video

 


Search for (options)